Inicio > Redes > Como Configurar DHCP para varias Vlan´s

Como Configurar DHCP para varias Vlan´s

Tengamos en cuenta que una Vlan esta en capa 2 y DHCP en capa 3, así que es necesario que el tráfico cuente con un dispositivo de Capa 3 (Router) para poder transmitir entre Vlan.

 

Una Vlan tiene tres funciones principales:

-Limita el tamaño de dominios de broadcast

-Mejora el rendimiento de la red

-Proporciona un nivel de seguridad

Pero para poner a trabajar dichas Vlans se necesita

Un Puerto de enlace troncal: Es un enlace punto a punto entre el switch y otro dispositivo de red.

Los enlaces troncales transmiten el tráfico de diversas Vlan mediante un único enlace, y permiten que las Vlan se extiendan por toda la red.

Los puertos de enlace troncal son necesarios para transmitir el tráfico de diversas Vlan, Sin los puertos de enlace troncal, cada Vlan requiere una conexión separada entre switches.

Por ejemplo, una empresa con 100 Vlan requiere 100 enlaces de conexión. Este tipo de disposición no es fácil de escalar y resulta muy costosa.

Los enlaces troncales ofrecen una solución a este problema al transportar tráfico de diversas Vlan a través del mismo enlace. Cuando esto sucede estas deben contar con una identificación.

IEEE 802.1Q es el método estandarizado y aprobado para llevar a cabo el etiquetado de dicha trama.

¿Como hacemos para configurar dichos dispositivos?

Primer Paso: Levantamos la interfaz. En la que están conectados los dispositivos.

Router>enable

Router#config terminal

Router(config)# interface fa0/0

Router(config-if)#no shutdown // Levantamos la interfaz.

Segundo Paso: Se crean 3 sub-interfaces (Cada sub-interfase pertenece a una Vlan), y cada Vlan tiene que tener asignada la encapsulación dot1Q seguida del número de la Vlan, esto se realiza en el Router.

RouterA(config)#interface fa0/0,10

RouterA(config-subif)#encapsulation dot1Q 10

RouterA(config-subif)#ip address 172.16.10.1 255.255.255.0

RouterA(config-subif)#exit

RouterA(config)#interface fa0/0,20

RouterA(config-subif)#encapsulation dot1Q 20

RouterA(config-subif)#ip address 172.16.20.1 255.255.255.0

RouterA(config-subif)#end

Tercer Paso: Le asignamos nombre a cada Vlan, esto  en el Switch

Switch1(config)#vlan 10

Switch1(config-vlan)#name Faculty

Switch1(config-vlan)#exit

Switch1(config)#vlan 20

Switch1(config-vlan)#name Students

Switch1(config-vlan)#exit

Switch>show vlan // Muestra la información de las Vlan’s

Cuarto Paso: Configurar en el Switch  las interfaces a las que pertenece cada Vlan.

Switch1(config)#interface range fa0/1-12

Switch1(config-if)#switchport mode access

Switch1(config-if)#switchport access vlan 10

Switch1(config-if)#exit

Switch1(config)#interface fa 0/13-24

Switch1(config-if)#switchport mode access

Switch1(config-if)#switchport access vlan 20

Switch1(config-if)#exit

Quinto Paso: Configurar el dhcp en el router

Router(config)#interface fa0/0.10

Router(config-subif)#ip dhcp pool  vlan 10// Ponemos el nombre del pool

Router(dhcp-config)#network 172.16.10.0 255.255.255.0

Router(dhcp-config)#default-router 172.16.10.1

Router(dhcp-config)#end

Estos serian los pasos a seguir para configurar varias Vlan, por dhcp espero este aporte les ayude en algo.

No dejen de comentar, gracias.

Categorías:Redes
  1. 10 julio, 2012 a las 10:51 PM

    Muy util el tutorial

  2. alejandro
    31 diciembre, 2014 a las 10:09 AM

    mucgas gracias esta bien util pero no me dejo en packet tracer🙂 saludos

  3. 9 noviembre, 2015 a las 6:21 PM

    Gracias me sirvió mucho tu procedimiento, ahora viene lo bueno tirar cables y crear la parte física, muchas gracias

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: